[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] pvremove won't work



On Tue, Jun 09, 2009 at 12:25:10PM +0200, Stefan Radovanovici wrote:

On 6/9/2009 11:46 AM, Bryn M. Reeves wrote:

Use dmsetup:

$ dmsetup info --maj 252 --min 1

(the output above shows dm is using 252 as its major number for this
device on your system).

At a guess it looks like you somehow removed the PV from the VG while a
logical volume was mapped on it.

First of all, thanks for the info. I am not a LVM expert and this is useful information. dmsetup shows this:

root neriak:/sys/block/sda/sda4/holders/dm-1# dmsetup info --maj 252 --min 1
Name:              storage-pvmove0
State:             ACTIVE
Read Ahead:        256
Tables present:    LIVE
Open count:        0
Event number:      1
Major, minor:      252, 1
Number of targets: 1
UUID: LVM-SS2wO5K12BwSo1iceXVSiTaYPQzdgEuUoOPgGYKKRLO109x4837eAHZeiSmzzEqW

I think I somehow messed up while trying to get rid of /dev/sda4. I used a GUI for this not the CLI, first I tried to move the extents to other PVs (which I think is that pvmove does) and then to actually remove it from the group (which is probably what vgreduce does). If I am not mistaken, the first operation gave an error even though it appeared to have worked somehow at the time.

it seems to be some leftover from the pvmove operation, unfortunately i
have no idea if some data was not actually moved correctly.
did you record the error message the pvmove operation reported?

Regards,
L.

--
Luca Berra -- bluca comedia it
        Communication Media & Services S.r.l.
 /"\
 \ /     ASCII RIBBON CAMPAIGN
  X        AGAINST HTML MAIL
 / \


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]