[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Stale NFS Handle on a system with no NFS mounts

My laptop battery was running low last night and Fedora started shutting down gracefully instead of just coming to a hard stop.  I was sitting right there so I was able to get a power plug connected to the system in time and the system did indeed stay up.  I used my system a while longer and then shut down for the night.  This morning when I powered it back on the system wouldn't boot.  Turning off rhgb I saw the system was complaining about not being able to access /lib/libdbus-1.so.3 giving an error 116.

Booting into single user mode I ran `ls -l /lib/libdbus-1*` and got the following output
ls: cannot access /lib/libdbus-1.so.3: Stale NFS file handle
lrwxrwxrwx. 1 root root     23 2009-09-17 08:23 /lib/libdbus-1.so -> /lib/libdbus-1.so.3.4.0
-rwxr-xr-x. 1 root root 261756 2009-06-27 19:14 /lib/libdbus-1.so.3.4.0

I tried to remake the symlink to libdbus-1.so.3 but ln was not able to access the file either.  Another thing I tried was booting into another linux install that I have on this computer and running fsck from there.  That yeilded no errors or warnings and the issue still persists.

A couple of forum posts led me to suspect that LVM may be involved with this somehow, but I didn't see anything when I searched this list's archives.  My system is a fairly standard Fedora 11 x86 install, everything is on one ext3 LVM partition except for /boot.  I have prepared an lvmdump archive if anyone is interested in seeing it.

So what do you think?  Is this an LVM thing, or am I barking up the wrong tree?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]