[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] [SOLVED]: lvm2 and partition shringkin: superblock/filesystem size mismatch



mke2fs -b 4096 -t ext3 -S /dev/mapper/mygroup-home

on the unmounted file system solved my issue.

Joh

Johannes Graumann wrote:

> Hi,
> 
> I'm running debian testing and "/home" is an ext3 fs. I run the following
> order of commands to shrink the fs and the corresponding partition:
> 
> e2fsck -f /dev/mapper/mygroup-home
> resize2fs /dev/mapper/mygroup-home 55329357
> lvreduce -L 208.5g /dev/mapper/mygroup-home
> 
> The latter was supposed to be .5g bigger than necessary (paranoia
> regarding the data integrity kicking in).
> 
> "e2fck /dev/mapper/mygroup-home" now stops with superblock/filesystem size
> mismatch, but I can't grow the fs into the new partition size, as
> "resize2fs" wants "e2fsck" (stopping with the mismatch) first.
> 
> The fs is mountable and everything seems allright otherwise.
> 
> Any pointers on how to update the superblock's size statement?
> 
> Thanks, Joh
> 
> _______________________________________________
> linux-lvm mailing list
> linux-lvm redhat com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]