[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] /dev/dm-0 instead of /dev/mapper/mygroup-myvol in "mount" output



On Fri, Jul 9, 2010 at 9:53 AM, Benjamin Henrion <bh udev org> wrote:
> Hi,
>
> I have managed to setup an LVM loopback file as a harddisk to mount.
>
> Now, I need the vzdump utility to detect the fact that it is LVM
> based, and it keeps saying that it cannot detect the LVM volume group:
>
> http://openvz.org/pipermail/users/2010-July/003623.html
>
> "unable to detect lvm volume group"
>
> Everything works fine when mount displays that the file is mounted
> with /dev/mapper/mygroup-myvol, on the opposite, it does not work when
> mount outputs /dev/dm-0 in its list.
>
> Any idea how I could force mount to use /dev/mapper/mygroup-myvol
> instead of /dev/dm-0?

On one machine it creates rightly a device on /dev/mapper:

root buzek /dev/mapper [68]# l
total 0
crw-rw---- 1 root root  10, 59 2010-07-09 09:32 control
brw-rw---- 1 root disk 254,  0 2010-07-09 10:44 openvzgroup-openvzvol

While on the other machine where is does not work, it makes a symlink
to /dev/dm-0:

root chainsaw /dev/mapper [25]# l
total 0
crw-rw---- 1 root root 10, 59 2010-07-09 10:28 control
lrwxrwxrwx 1 root root      7 2010-07-09 10:46 openvzgroup-openvzvol -> ../dm-0

Any idea why this difference?

-- 
Benjamin Henrion <bhenrion at ffii.org>
FFII Brussels - +32-484-566109 - +32-2-4148403
"In July 2005, after several failed attempts to legalise software
patents in Europe, the patent establishment changed its strategy.
Instead of explicitly seeking to sanction the patentability of
software, they are now seeking to create a central European patent
court, which would establish and enforce patentability rules in their
favor, without any possibility of correction by competing courts or
democratically elected legislators."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]