[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Imaged a drive, now kernel panics

  You mentioned that the old drive is IDE.  If so,
You may be running into a couple problems I've had.
I take it the new drive is SATA, SAS, or SCSI?
Did you edit /etc/fstab to change hda to sda, hdb
to sdb, etc., before running mkinitrd?

  The existing kernel may not have the needed drivers
compiled in, the drivers for the particular chipset
and whatever SCSI drivers or modules are needed.
Assuming that rescue kernel matches the kernel on
the failed drive, mkinitrd _should_ take care of that
if /etc/fstab is correct.  Might it might look at

I also tried moving the current kernel out of the
way and using 'mkinitrd' to rebuild the image (after
chrooting and making sure everything looked fine)

   Be sure to bind /proc, /sys, /dev, and /selinux
into the chroot.  We want to be able to see /dev/sda
it order to set up to boot from it.  Along the same lines,
double check that any other partitions, primarily /boot,
are mounted in the chroot.

   That should pretty much you, but before I figured out
some of the possible failure modes I build modified several
initrd by hand.  You can debug the init script with simple
echo statements much like you would debug any simple

   One last thing - on some motherboards the BIOS can
be set to present a SATA drive as if it were IDE, I
understand.  qemu-kvm can also present a hard drive image
as either SCSI or IDE, regardless of the actual underlying
hardware.  So you could present your SATA or SCSI drive
as an IDE drive in order to make the old initrd and kernel
Ray Morris
support bettercgi com

Strongbox - The next generation in site security:

Throttlebox - Intelligent Bandwidth Control

Strongbox / Throttlebox affiliate program:

On 06/05/2010 07:59:49 PM, Digimer wrote:
Hi all,

  I am sure this is a fairly common issue, but it's stumping me.

I have an old server's drive (IDE) that has CentOS 4 on it. The mainboard fried, so I imaged the drive using 'dd' onto a new drive and tried booting from it. Not surprisingly, it failed to boot. Specifically:

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version starting
  Reading all physical volumes.  This may take a while...
  No volume groups found
  Volume group "VolGroup00" not found
ERROR: /bin/lvm exited abnormally! (pid 321)
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

When I boot off the DVD using 'linux rescue', it successfully finds the partitions and mounts them. I can 'chroot /mnt/sysimage' just fine. I also tried moving the current kernel out of the way and using 'mkinitrd' to rebuild the image (after chrooting and making sure everything looked fine).

  Any idea what I might be missing?


E-Mail:         linux alteeve com
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org

linux-lvm mailing list
linux-lvm redhat com
read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]