[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Multipath / LVM2



hello
thanks for trying to help :)

I've changed the filter and preferred_names variables to

preferred_names="^/dev/mapper/"
filter=["a|/dev/mapper/.*|", "r/.*/"]

without luck :(

new pvscan output:
http://pastebin.com/5PysR0rD


> On Tue, Mar 16, 2010 at 05:40:20PM +0100, blub trans am wrote:
>>hello
>>
>>I have troubles to get multipathing working on gentoo. I have an
>> identical
>>setup working on a debian box.
>>The problem is that LVM does not detect labels on the multipath device
>>node; instead it does try to use a physical path (eg /dev/sda1)
>>
>>the device nodes /dev/dm-X are not automaticaly created like they get on
>>debian, I did run dmsetup mknodes which did not create /dev/dm-X nodes,
>> so
>>i created /dev/dm-0 with the minor/major of the corresponding
>> /dev/mapper/
>>node. I don't know if this is a problem.
>>
>>anyway, I've pasted alot of output to http://pastebin.com/wheL4nyE
>>
> change the preferred_names in /etc/lvm.conf to reference /dev/mapper
> entries before /dev/sd
>
> eg:
> preferred_names = [ "^/dev/mapper/" ]
>
> L.
>
>
> --
> Luca Berra -- bluca comedia it
>          Communication Media & Services S.r.l.
>   /"\
>   \ /     ASCII RIBBON CAMPAIGN
>    X        AGAINST HTML MAIL
>   / \
>
> _______________________________________________
> linux-lvm mailing list
> linux-lvm redhat com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]