[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Two questions about cluster support (2 problems, actually)



On 10-03-16 04:50 PM, Milan Broz wrote:
# pvdisplay
    connect() failed on local socket: Connection refused
    WARNING: Falling back to local file-based locking.
    Volume Groups with the clustered attribute will be inaccessible.
    "/dev/drbd0" is a new physical volume of "399.99 GB"

apparently clvmd is not running, you cannot see clustered PVs.

Anyway, the DRBD need to setup filters to work properly with lvm2,
(filter out underlying drbd device)
(or update to new lvm2 version, RHEL5/CentOS5 build will be available
in next minor update).
For more info see https://bugzilla.redhat.com/show_bug.cgi?id=530881
(not sure it is related, but for archive and other users...)

Milan

Thanks for the reply, Milan!

I had made the change to the 'filter' argument, but I was using 'filter = [ "a|drbd.*|", "r|.*|" ]'. I switched to 'filter = [ "a|^/dev/drbd|", "a/sd*/", "r/.*/" ]' and started 'clvmd'. This seems to have solved the problem, so thank you.

If I may ask another question though;

My DRBD device is '/dev/drbd0' which sits on either node's '/dev/san0x/lv02'. When I ran 'pvcreate /dev/drbd0' the PV was created successfully and 'pvdisplay' shows the new PV on both nodes. However, I see this:

# pvdisplay
  --- Physical volume ---
  PV Name               /dev/sda2
  VG Name               san02
  PV Size               465.51 GB / not usable 14.52 MB
  Allocatable           yes
  PE Size (KByte)       32768
  Total PE              14896
  Free PE               1407
  Allocated PE          13489
  PV UUID               ru7tmz-Qd4d-aatg-4ReY-TPPq-gMll-Z5ZOkL

  "/dev/san02/lv02" is a new physical volume of "399.99 GB"
  --- NEW Physical volume ---
  PV Name               /dev/san02/lv02
  VG Name
  PV Size               399.99 GB
  Allocatable           NO
  PE Size (KByte)       0
  Total PE              0
  Free PE               0
  Allocated PE          0
  PV UUID               MjwXhY-T3dw-IUkI-ZdSI-FKEB-KJdq-nl9GUo

Note that the 'PV Name' is '/dev/san02/lv02' but the device passed was 'pvcreate /dev/drbd0'. Is this correct? I'd expect it to show the DRBD device, not the DRBD's underlying logical volume.

--
Digimer
E-Mail:         linux alteeve com
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]