[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Confusion mounting old LVs on new system.



Something that I thought would be simple turned out ta not ta be simple at all. What's new.

Anyway, the outputs:

 # df -h
Filesystem            Size  Used Avail Use% Mounted on
rootfs                 20G  9.2G  9.6G  49% /
devtmpfs              1.9G  288K  1.9G   1% /dev
tmpfs                 2.0G  1.3M  2.0G   1% /dev/shm
/dev/mapper/system-root
                       20G  9.2G  9.6G  49% /
/dev/sda1             152M   30M  114M  21% /boot
/dev/mapper/system-home
                      437G   14G  402G   4% /home

 # /sbin/fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009017e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      321535      159744   83  Linux
/dev/sda2          321536   976773119   488225792   8e  Linux LVM

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006e47a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63      144584       72261   83  Linux
/dev/sdb2          144585    31599854    15727635   8e  Linux LVM
/dev/sdb3        31599855  1953520064   960960105   8e  Linux LVM

Disk /dev/mapper/system-home: 476.3 GB, 476317745152 bytes
255 heads, 63 sectors/track, 57909 cylinders, total 930308096 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/system-home doesn't contain a valid partition table

Disk /dev/mapper/system-root: 21.5 GB, 21474836480 bytes
255 heads, 63 sectors/track, 2610 cylinders, total 41943040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/system-root doesn't contain a valid partition table

Disk /dev/mapper/system-swap: 2147 MB, 2147483648 bytes
255 heads, 63 sectors/track, 261 cylinders, total 4194304 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/system-swap doesn't contain a valid partition table

Disk /dev/mapper/OLDhdd-OLD: 984.0 GB, 984021467136 bytes
255 heads, 63 sectors/track, 119633 cylinders, total 1921916928 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/OLDhdd-OLD doesn't contain a valid partition table

 # cat /proc/partitions
major minor  #blocks  name

   8        0  488386584 sda
   8        1     159744 sda1
   8        2  488225792 sda2
   8       16  976762584 sdb
   8       17      72261 sdb1
   8       18   15727635 sdb2
   8       19  960960105 sdb3
 253        0  465154048 dm-0
 253        1   20971520 dm-1
 253        2    2097152 dm-2
 253        3  960958464 dm-3

 # cat /etc/fstab
/dev/system/swap     swap                 swap       defaults              0 0
/dev/system/root     /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV9A100021-part1 /boot                ext4       acl,user_xattr        1 2
/dev/system/home     /home                ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

 # mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=1985000k,nr_inodes=496250,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/mapper/system-root on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data="">
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /boot type ext4 (rw,relatime,user_xattr,acl,barrier=1,data="">
/dev/mapper/system-home on /home type ext4 (rw,relatime,user_xattr,acl,barrier=1,data="">
securityfs on /sys/kernel/security type securityfs (rw,relatime)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
gvfs-fuse-daemon on /home/borelli/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

 # pvscan
  /dev/sdc: open failed: No medium found
  /dev/sdc: open failed: No medium found
  Couldn't find device with uuid CSGXpY-YEJ7-4qsf-KtdC-ft1u-IOaN-QSecuY.
  PV /dev/sdb3        VG OLDhdd   lvm2 [916.44 GiB / 0    free]
  PV /dev/sdb2        VG system   lvm2 [15.00 GiB / 0    free]
  PV unknown device   VG system   lvm2 [916.44 GiB / 0    free]
  PV /dev/sda2        VG system   lvm2 [465.61 GiB / 0    free]
  Total: 4 [2.26 TiB] / in use: 4 [2.26 TiB] / in no VG: 0 [0   ]

 # vgscan
  Reading all physical volumes.  This may take a while...
  /dev/sdc: open failed: No medium found
  Found volume group "OLDhdd" using metadata type lvm2
  /dev/sdc: open failed: No medium found
  Couldn't find device with uuid CSGXpY-YEJ7-4qsf-KtdC-ft1u-IOaN-QSecuY.
  Found volume group "system" using metadata type lvm2
  Found volume group "system" using metadata type lvm2

 # lvscan
  ACTIVE            '/dev/OLDhdd/OLD' [916.44 GiB] inherit
  /dev/sdc: open failed: No medium found
  Couldn't find device with uuid CSGXpY-YEJ7-4qsf-KtdC-ft1u-IOaN-QSecuY.
  inactive          '/dev/system/home' [895.00 GiB] inherit
  inactive          '/dev/system/root' [34.44 GiB] inherit
  inactive          '/dev/system/swap' [2.00 GiB] inherit

I thought I was doing a simple install to a new disk. I use openSUSE and I thougt that I could install with the old disk unplugged then plug in the old disk and boot the new system then access the old home partition to retrieve my data, settings, etc.

The Partitoiner in Yast tells me that it will not mount a partition with unknown or non-existent file system. I'm pretty sure the filesystem is still there and I want to be careful to keep it intact. I'm not practiced enough to go it on my own.

/sda is my new disk 500 Gib it is working correctly as far as I can tell.
/sdb is my old disk and /sdb3 is the partition I want to mount.
in pvscan there is a mistake where there is only 1.5 Tib disk space in my machine.
I used Yast Partitioner to change the Volume Group names I think.
I'm still a little unclear about the distinction between PVs and LVs and VGs, but I'm starting to get it.
I'm paranoid to try anything else lest I lose my data.

Anyway, whatever help I can get would be greatly appreciated.
Thanks,
AARON

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]