[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] lvm_vg_create_lv_linear() stuck in dm_udev_wait()



Dne 21.8.2011 20:14, Alexander Lyakas napsal(a):
> Greetings all,
> on stock ubuntu natty, using liblvm 2.02.66, sometimes
> lvm_vg_create_lv_linear () gets stuck in the following stack.
> 
> #0  0x00007f3b9636a0f7 in semop () from /lib/x86_64-linux-gnu/libc.so.6
> #1  0x00007f3b9606863c in dm_udev_wait () from /lib/libdevmapper.so.1.02.1
> #2  0x00007f3b973df41b in ?? () from /lib/liblvm2app.so.2.2
>

dmsetup udevcomplete_all

this should finish the execution of this command.

> 
> I realize that somehow it is related to udev synchronization. In my
> application, I have a udev monitor for "block" subsystem type, but
> currently it does nothing with the events it receives (it calls
> udev_monitor_receive_device(), udev_device_get_action() and then
> udev_device_unref() for every event. I plan in the future to use it
> for waking up other threads.
> 
> Can somebody pls advise on how to investigate this issue. It does not
> happen always.


My assumption is - you Debian system is using non-upstream Debian deviation of
udev rules and those are broken (I guess some related discussion might be googled)

Another issue which is currently being explored is the namespace usage - but I
think this is not related to the problem you are seeing.

Anyway I'd strongly suggest to use newer lvm package (either build form CVS)
or at least  Debian unstable version - as 2.02.66 is very old one.

Zdenek


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]