[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] sharing attr on clustered volume -- cannot see open attribute



hi,

first of all, sorry for the long subject...
i do not know how to explain myself, so any faq/manual will be of course appreciated.

now,
i have a test cluster, gentoo based.
cluster 3.1.7, corosync 1.4.2, lvm2 2.02.88.
clvm is built with following flags:
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-readline --disable-selinux --enable-pkgconfig --with-confdir=/etc --sbindir=/sbin --with-staticdir=/sbin --libdir=/lib64 --with-usrlibdir=/usr/lib64 --enable-udev_rules --enable-udev_sync --with-udevdir=/lib/udev/rules.d/ --enable-dmeventd --enable-cmdlib --enable-applib --enable-fsadm --enable-static_link --with-mirrors=internal --with-snapshots=internal --with-lvm1=internal --with-cluster=internal --enable-cmirrord --with-clvmd=cman --with-pool=internal --with-dmeventd-path=/sbin/dmeventd CLDFLAGS=-Wl,-O1 -Wl,--as-needed

cluster.conf:
<cluster name="CEMCluster" config_version="2">
        <clusternodes>
                <clusternode name="pvsrv01" nodeid="1">
                </clusternode>
                <clusternode name="pvsrv07" nodeid="2">
                </clusternode>
                <clusternode name="pvsrv08" nodeid="3">
                </clusternode>
        </clusternodes>
</cluster>


now, i have the cluster working, i can see and create volumes and so on.

but when i mount a volume on node pvsrv07, i cannot see it as open in pvsrv08. also, clvmd (running in debug mode) does not show me anything when i mount or unmount volumes.

any hints?

thanks
Daniele


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]