[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] more vg problems or oddities...not using dmsetup remove seems to be bad?

tried to remove an unmounted active snapshot.

lvremove said it wouldn't remove an active snapshot.

Tried -an -- can't change active snapshot.

Tried turning off monitoring --monitor -n
It gave no message
tried removing again...can't remove active snap

tried --ignoremonitoring

no message but still can't remove

tried -- merging it...

Said it couldn't merge with open origin,
then merging with origin on next activation...

Now still can't remove, but says "
 Can't remove merging snapshot logical volume "Home-2011.09.03-00.28.36"

decided to try dmsetup remove --

it couldn't remove it either -- resource/device busy...

So now I'm concerned...is it going to try to merge back any changes it recorded by reversing them?

i.e. put the original volume back the way it was when the snapshot started?

Says it couldn't do it on open volume -- does that mean it won't start this until I reboot,
then it will take a long time to become active?

seems like the dmsetup remove of the parts was the safest way to
kill off an active snapshot...but this feels contorted.

I'm wondering if I really want this 'merge' it wants to do...and if not, how do I abort


(hoping system stays up until I get this sorted out!)...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]