[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Getting 'incorrect semaphore state' on self configured server kernel



> >>> # lvcreate -L100M -n foobar -v array 
> >>> /dev/array/foobar: not found: device not cleared
> >>> Aborting. Failed to wipe start of new LV.
> >>> semid 983040: semop failed for cookie 0xd4d19ee: incorrect
> >>> semaphore state Failed to set a proper state for notification
> >>> semaphore identified by cookie value 223156718 (0xd4d19ee) to
> >>> initialize waiting for incoming notifications.
> >> 
> >> I appreciate all help I can get.
> >> 
> >
> > I still haven't solved this.. who is willing to lend me a hand
> > please?
>
> A diff -u of a working kernel config vs a non-working config would
> possibly help.
> --
> Scott Merrilees

(I'm replying to a digest so sorry if the formatting is a bit off. I
disabled digests for now.)

Scott, thanks for your suggestion. I followed it, changed more settings
just for testing, and still can't get it to work without these errors.

So I tried to build a kernel, same version and same config on a
different distribution, this time I chose AlpineLinux. And lo, the
errors are not occurring there.

This makes me suspicious about Archlinux's udev version and/or methods,
but the question about why their own kernel doesn't have these issues
remains.

What to try next? Where to look?

-- 
Stay in touch,
Mark van Dijk.                  ,------------------------------------
-------------------------------'            Sun Aug 12 15:21 UTC 2012
Today is Prickle-Prickle, the 5th day of Bureaucracy in the YOLD 3178
Celebrate Zaraday


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]