[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] lvremove snapshot hangs LVM system



It's been a long time, but finally I had time to test it a bit.

As Ray Morris suggested I tried disabling selinux, with no luck. It happens all the same.

Any way, I did some more testing and I think I detected the problem, but not yet the solution.
The problem is that "lvremove" will fail removing the "dm" device. Nothing changes on "dmsetup ls" after an "lvremove" yet if "lvremove" says the removal was successful.

If I try to remove the "dm" before the "lvremove" then it seems to work:
[root node2 ~]# dmsetup remove vgtest01-snap02 && dmsetup remove vgtest01-snap02-cow && lvremove /dev/vgtest01/snap02
  Logical volume "snap02" successfully removed


But yet if I try any other "lvm" command:
[root node2 ~]# lvcreate -s -L 20M -n snap10 /dev/vgtest01/lvtest-snap01
  /dev/vgtest01/snap10: not found: device not cleared
  Aborting. Failed to wipe snapshot exception store.

So I have to restart "clvm (which is better than rebooting).

I tried changing the snapshot to  "--monitor n" and "--noudevsync" with the same luck.

So, I guess something is failing in the process to remove the "dm",... I will keep looking...

Do someone have any ideas?

Thanks!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]