[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] lvextend NEVER works but screws up



thought I will update this thread , there is no e4fsprogs on  RHEL 6 for ext4, and e2fsprogs ( e2fsck/resize2fs works just fine ) .

On Wed, Aug 29, 2012 at 2:00 PM, tariq wali <ganaiwali gmail com> wrote:
not sure if -r with lvresize would pick ext4 filesystem also . but I will give it a try ..thanks


On Tue, Aug 28, 2012 at 2:39 PM, Zdenek Kabelac <zkabelac redhat com> wrote:
Dne 27.8.2012 13:46, tariq wali napsal(a):
Guys , thanks much for your time on the issue, really appreciate it . I had
tried everything suggested so far (lvresize/extend) updated filesystem
tools etc

@Stuart D Gathman , YOU ARE THE MAN SIR :) and nailed it down .

I wanted to reproduce the same issue again and i did that not know how
ignorant I was being ..

# lvextend -L +40G /dev/vg0/bin-logs
   Extending logical volume bin-logs to 110.00 GB
   Logical volume bin-logs successfully resized


lvs
   LV       VG   Attr   LSize   Origin Snap%  Move Log Copy%  Convert
   bin-logs vg0  -wi-ao *110.00G*

   data     vg0  -wi-ao 380.00G

resize2fs /dev/vg0/bin-logs
resize2fs 1.39 (29-May-2006)
resize2fs: Filesystem has unsupported feature(s) while trying to open
/dev/vg0/bin-logs
Couldn't find valid filesystem superblock.

#this is where I would get psyched , i did the same thing to all my ext2/3
filesystems and have extended file systems online without an issue for
years ..but did I fforget the file system type this time , yes indeed I for
got we have started doing ext4 on all our new servers and didn't realise
ext4 fancies it's own bells and whistles ..

I ran the all new resize4fs as suggested by Stuart , and it made my day in
fact it made for the whole week's frustration :)

resize4fs /dev/vg0/logs
resize4fs 1.41.12 (17-May-2010)
Filesystem at /dev/vg0/logs is mounted on /bin-logs; on-line resizing
required
old desc_blocks = 7, new_desc_blocks = 9
Performing an on-line resize of /dev/vg0/logs to 37408768 (4k) blocks.

The filesystem on /dev/vg0/logs is now 37408768 blocks long.


lvs
   LV   VG   Attr   LSize   Origin Snap%  Move Log Copy%  Convert
   data vg0  -wi-ao 350.00G
   logs vg0  -wi-ao *142.70G *



PS: I am raving fan of lvm all over again :)


thanks everyone and issue closed !


How about checking 'man lvresize'
and using option  '-r'  i.e.:

lvresize -r -L +40G /dev/vg0/bin-logs

That would be time-saver...

Zdenek




--
Tariq Wali.




--
Tariq Wali.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]