[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] raid1 Failed to activate new LV



Hi,

I'm trying to create a raid1 but when I want create my LV, I get the
following error : 
# device-mapper: reload ioctl on failed: Invalid argument
# Failed to activate new LV.

My command is : lvcreate --type raid1 -m 1 -L 55G -n lv0 vg0

Vgdisplay :
  --- Volume group ---
  VG Name               vg0
  System ID
  Format                lvm2
  Metadata Areas        2
  Metadata Sequence No  63
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                0
  Open LV               0
  Max PV                0
  Cur PV                2
  Act PV                2
  VG Size               1.09 TiB
  PE Size               4.00 MiB
  Total PE              285588
  Alloc PE / Size       0 / 0
  Free  PE / Size       285588 / 1.09 TiB
  VG UUID               k7hTZD-QXLt-LO34-Fc5P-vk5T-zcOL-2JgZmr

  --- Physical volumes ---
  PV Name               /dev/mapper/mpatha
  PV UUID               ccouAp-S0ew-vAWv-nRSc-VgA3-bzFi-pfHDqA
  PV Status             allocatable
  Total PE / Free PE    142794 / 142794

  PV Name               /dev/mapper/mpathd
  PV UUID               v3nfWQ-w7eU-jrnk-PDMW-Rxnc-cMAe-qn4F5e
  PV Status             allocatable
  Total PE / Free PE    142794 / 142794

If I do not specify the type, it works well ( lvcreate  -m 1 -L 55G -n
lv0 vg0) but in this case it's a mirror and I need a raid1.

Any help is welcome :)

Regards,
Thomas

# lvm version
  LVM version:     2.02.95(2)-RHEL6 (2012-10-16)
  Library version: 1.02.74-RHEL6 (2012-10-16)
  Driver version:  4.20.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]