[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] LVM snapshot with Clustered VG [SOLVED]



Hi Vladislav,

I finally succeeded making all working as expected!

What I did:
- compile corosync 2.3.0 (http://corosync.org/download/corosync-2.3.0.tar.gz) - compile libqb 0.14.4 (https://fedorahosted.org/releases/q/u/quarterback/libqb-0.14.4.tar.gz) - compile dlm_4.0.1 (http://git.fedorahosted.org/cgit/dlm.git/snapshot/dlm-4.0.1.tar.gz) - Compiled LVM 2.2.98 (http://git.fedorahosted.org/cgit/lvm2.git/snapshot/lvm2-2_02_98.tar.gz) with your PREVIOUS patch ( https://www.redhat.com/archives/linux-lvm/2013-January/msg00006.html )

I made a 2-node test cluster, both accessing a test iscsi target, all daemons load fine. Everything works as expected! Snapshotting is possible after -aey --force explicit exclusive locking, lvresize works as well.

Previously, I tried your latest patch. I had a plethiora of errors, starting with lvcreate failing:

#metadata/lv_manip.c:4137     Clearing start of logical volume "testvol2"
#device/dev-cache.c:599 /dev/san2/testvol2: stat failed: No such file or directory #metadata/lv_manip.c:4140 /dev/san2/testvol2: not found: device not cleared
#metadata/lv_manip.c:4620   Aborting. Failed to wipe start of new LV.

I need to add -Z n to have it created. After that, most activations failed, with error code 5. I went back to vanilla 2.2.98, all ok except exclusive locking, applied the initial locking patch and voila! All done.

Thanks for your support!
Andreas



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]