[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM & fstrim behaviour (Fedora 19)



Hi,

I'm testing fstrim on an LVM volume but it only seems to work the first
time I run it (just after mounting the volume).  When I run "fstrim -v
/mnt" for the first time it prints all the free blocks that is trimming
(almost all of the filesystem as it is empty) but subsequent runs just
output "0 bytes trimmed" no matter how many files I create/sync & delete
afterwards.  The "issue_discards" is set in lvm.conf.

If I do this over the raw device (/dev/sda3, same ext4 filesystem) I get
the output corresponding to the last deleted files every time I run fstrim.

## THIN ##

I also created a thin pool and a logical volume on that pool.  If I
mount this volume with "discard", I can see that TRIM is working by
doing an "lvs vgthin" (the Data Usage% grows as I create files & shrinks
as I delete files).  However, If I mount it without the "discard" option
(in order to use fstrim) I only see the data-usage reduction when I run
fstrim *just* for the first time.

Any help will be appreciated.

Thanks,
Jorge


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]