[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] LVM says physical volumes are missing, but they are not



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

On 05/30/2016 04:15 AM, Zdenek Kabelac wrote:
> Hi
> 
> Please provide full 'vgchage -ay -vvvv' trace of such activation
> command.
> 
> Also specify which version of lvm2 is in use by your distro.

2.02.133-1ubuntu10.  I ended up fixing it by doing a vgcfgbackup,
manually editing the text file to remove the MISSING flags, and then
vgcfgrestore.  My guess is that when I initially installed 16.04, I
forgot to install mdadm, and so the init scripts must have forced a
partial activation without the raid pvs present, and that set the
MISSING flag on those pvs in the metadata on the remaining drive.
Once set, there appears to be no way to remedy this other than what I
ended up doing.  It seems to me that having the volume actually
present should override the MISSING flag in the metadata, or at least
you should be able to clear the flag with pvchange.



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEcBAEBCgAGBQJXTJooAAoJEBB5UWFcu6UWfoEH/iYx2giltU+WiJO382qWCzy7
g73itTdrC9oTsQVtYaMqHNtnZQfjxBIzCilpSMfMU7xpvmWGA8rCgNBpc6CNx/29
YB4T4nEEvFgklGPfq6PLDrBwxgOWkiBgwbDtjxwrFAC2mDerx/Y5SXZHYZmne08t
aKT6noyDAaepMlxxzFg3YpD0zI4brcvQZ2WPlZy0T2KxfxDriwwcD6U2pyRla6Gf
7KMO5orF6lSqzDXogfWb4AEjSgiFAkTYsgV49gouunWsyJIsur7BFVtV9MmrEgOP
3CQmAdhVowefe3K2OSxZ3luBLT0aWD4yGo285w+/IhfTzeAC3b9srmFC2eU9Szo=
=mNGi
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]