[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] [PATCH] (6/11) re-introduce vg_read

Dave Wysochanski <dwysocha redhat com> writes:
> It is a little confusing have a vg_read_for_update() (only intended for
> WRITE) and a generic vg_read() (that allows both READ/WRITE) in the same
> API.  Should we have "vg_read_for_update()" (WRITE) and
> vg_read_for_query()" (READ) or something like that?
Well, is it? I tend to think about it like "select", and "select for update" in
SQL, although the analogy is not 100 % correct, I know. But I intended
vg_read_for_update as a convenience function that obviously points out that you
intend to update the VG (as opposed to just read it).

But, I suppose it's a bikeshed point. We however still want a generic vg_read,
for the iterator functions (in toollib) which need to pass a flag to
differentiate the read/write case.


Peter Rockai | me()mornfall!net | prockai()redhat!com
 http://blog.mornfall.net | http://web.mornfall.net

"In My Egotistical Opinion, most people's C programs should be
 indented six feet downward and covered with dirt."
     -- Blair P. Houghton on the subject of C program indentation

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]