[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[lvm-devel] [RFC PATCH]: Remove vg_might_exist() and let the caller decide the disposition of FAILED_NOTFOUND.



Peter, this should apply on top of your 11 vg_read() patches posted
1-12-2009.  I've been thinking about ways to clean up vg_might_exist()
and this is one potential route but has a downside.

It makes the code simpler and more readable but does have one shortfall.
Normally when a VG does not exist we print an error message to this
effect.  This patch removes the message.  One approach is to add another
flag (ugh - we just removed one) to this effect.

Might not be possible this go around but perhaps this is close enough to
spur some thoughts of how we could clean this up.

Attachment: 0001-Remove-vg_might_exist-and-let-the-caller-decide-th.patch
Description: application/mbox


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]