[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] [PATCH 3/7] Remove snapshot_count from VG and use function instead.



On Wed, May 06, 2009 at 04:43:00PM +0200, Milan Broz wrote:
> -	 * The following relationship should always hold:
> -	 * dm_list_size(lvs) = lv_count + 2 * snapshot_count
> +	 * logical volumes count

Please leave the description of dm_list_size(lvs).
  "Number of snapshots" instead of snapshot_count?
  (Or the new function?)

> +unsigned snapshot_lvs_in_vg(const struct volume_group *vg)
> +{
> +	struct lv_list *lvl;
> +	unsigned lv_count = 0;

A confusing alternative use for a variable called lv_count?
'unsigned snapshot_count'?

Ack.

Alasdair.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]