[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] [PATCH 02/29] Fix check for empty system_dir



> > In that case, please use !strlen(str), as that is much more readable.
> In this case I believe it's common practice not only in our source to check
> the first char for '\0' when checking for empty string - so are we planning to
 
We use *str or str[0] in lots of places - it's pretty common practice I think
and shouldn't really surprise anyone.  !strlen(str) is also fine by me
where that adds clarity.

Alasdair


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]