[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] [PATCH 04/23] Remove dead assignment of lock_flags



On 01/05/2011 01:30 AM, Alasdair G Kergon wrote:
> On Wed, Dec 22, 2010 at 11:11:36AM +0100, Zdenek Kabelac wrote:
>> I always thought that's why /* comments */  were invented ;) for things like
>> this, but anyway in this case if you prefer to keep the unused value present -
>> I'll hide it only for my local scan-builds :)
>  
> So do a patch that moves it into a comment?

That code is messy, and it should be cleaned - the lock_vg() name is misleading
(it should be called pre_lock_vg(), it should take pre-parsed flags and not parse
it itself from client struct - the same like lock_lv etc)

So if you think cleaning one variable help anything, better do it than spent another
week discussing it :-)

Milan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]