[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] [PATCH 1/3] Require stable libudev version and remove defines used for former unstable versions



On 03/21/2011 03:40 PM, Peter Rajnoha wrote:
> Libudev got stabilized in v143. Require that version directly in configure and
> remove "define LIBUDEV_I_KNOW_THE_API_IS_SUBJECT_TO_CHANGE" that was needed
> for unstable versions of libudev.

ack.

> -		     [UDEV_PC="libudev"; UDEV_LIBS="-ludev"],
> -		     [AC_MSG_ERROR([bailing out... libudev library is required])])
> +	PKG_CHECK_MODULES(UDEV, libudev >= 143, [UDEV_PC="libudev"],
> +			  [AC_MSG_ERROR([bailing out... libudev library version >= 143 is required])])

One day, someone, somewhere, somehow .... could fix static build here.. (UDEV_LIBS)

Milan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]