[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [lvm-devel] libcunit not found but installed [was Re: more complex example_cmdlib.c ? ]



Dne 25.11.2013 16:41, Oliver Rath napsal(a):
Hi Zdenek!

Am 25.11.2013 16:11, schrieb Zdenek Kabelac:
[..] Maybe look at  test subdir  - there  are some API tests and
also some python scripts which are trying to exercise some
supported pieces.

I tried to install lvm with --enable-testing , but the needed cunit
seems not to be found on my ubuntu 12.04.3 System:

lvm2# dpkg-query -l libcunit1
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
          Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler:
GROSS=schlecht)
||/ Name                     Version                  Beschreibung
+++-========================-========================-================================================================
ii  libcunit1                2.1-0.dfsg-9             Unit Testing
Library for C

lvm2# dpkg-query -L libcunit1
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libcunit1
/usr/share/doc/libcunit1/changelog.gz
/usr/share/doc/libcunit1/copyright
/usr/share/doc/libcunit1/changelog.Debian.gz
/usr/share/CUnit
/usr/share/CUnit/CUnit-List.dtd
/usr/share/CUnit/CUnit-List.xsl
/usr/share/CUnit/CUnit-Run.dtd
/usr/share/CUnit/CUnit-Run.xsl
/usr/share/CUnit/Memory-Dump.dtd
/usr/share/CUnit/Memory-Dump.xsl
/usr/lib
/usr/lib/libcunit.so.1.0.1
/usr/lib/libcunit.so.1


lvm2# ./configure --with-thin=internal --with-replicators=internal
--enable-udev_sync --enable-udev_rules --enable-python_bindings
--enable-applib --enable-cmdlib --enable-testing

  [..]

checking pkg-config is at least version 0.9.0... yes
checking for PKGCONFIGINIT... no
pkg-config initialized
checking for CUNIT... no
configure: error: Package requirements (cunit >= 2.0) were not met:

No package 'cunit' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CUNIT_CFLAGS
and CUNIT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


What is going wrong here? TFH!



Google:

https://launchpad.net/ubuntu/+source/cunit

Zdenek


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]