[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Ovirt-devel] [PATCH 3/5] API for Hardware Pools



On Thu, 2008-08-07 at 16:02 -0400, Scott Seago wrote:
> David Lutterkort wrote:
> > +                    # FIXME: Why does move_hosts need an explicit pool_id ?
> >   
> The pool_id specifies what pool we're moving the hosts to, although it 
> probably makes sense to default this to the current ID. i.e. move_hosts 
> without ID moves them _here_ -- move_hosts _with_ ID moves them _there_.

What I was getting at with this comment is that HardwarePool.move_hosts
is an instance method, but does not depend on the instance it is called
on. It should either become a class method or use the id of the pool
it's called on (in which case 'add_hosts' is probably a better name)

David



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]