[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Ovirt-devel] [PATCH] configure Cobbler instance in oVirt appliance



Ian Main wrote:
On Thu, 21 Aug 2008 01:41:42 +0200
Alan Pevec <apevec redhat com> wrote:

Minimal Fedora install tree is imported into the image during appliance creation,
at appliance firstboot Cobbler distro and profiles are created,
using non-mirrored repositories to save appliance disk space and setup time.

Cobbler entries for each "fake" oVirt Node in developer setup is added
if you add more oVirt Nodes, define them as Cobbler system:
  cobbler system add --name=NodeName --profile=oVirt-Node-x86_64 --mac=00:11:22:33:44:55 --netboot-enabled=1
otherwise they will PXE boot to the default Cobbler boot menu, where
oVirt Node can be manually choosen

Perry and I spent a lot of time messing about with this one.  Turns out the config is not picked up for some bizarre reason until you restart cobbler.  We tried cobbler sync too with no success.  Here is what I added and it tested and worked fine:

--- a/wui-appliance/wui-devel.ks
+++ b/wui-appliance/wui-devel.ks
@@ -336,6 +336,7 @@ cobbler system add --netboot-enabled=1 --profile=oVirt-Node-$arch \
   --name=node4 --mac=00:16:3e:12:34:58
 cobbler system add --netboot-enabled=1 --profile=oVirt-Node-$arch \
   --name=node5 --mac=00:16:3e:12:34:59
+service cobblerd restart
 set +x
 echo "Add new oVirt Nodes as Cobbler systems to make them PXE boot oVirt Node image directly."
 echo "Alternatively, choose oVirt-Node-$arch in default Cobbler boot menu."


If you add that, it all works fine on boot up.  I'm installing fedora now!  ACK with that change. :)

	Ian


_______________________________________________
Ovirt-devel mailing list
Ovirt-devel redhat com
https://www.redhat.com/mailman/listinfo/ovirt-devel

If you're talking about system record changes not showing up in /var/lib/tftpboot? These should just be applied automatically.

Also, what cobbler version are you using?

--Michael


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]