[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Ovirt-devel] VM Installation problem (and proposed solution)



Hello all (Ian especially),
     apevec pointed out a problem with installation of guests under oVirt.  What
currently happens is that after you finish the installation of (say) Fedora in a
VM, the VM reboots, but then immediately PXE boots again.  This is because we
haven't killed the guest and re-defined the XML to have the boot device be the
hard drive, like it should.
     Now, we could solve this by having a flag in the database for "install",
setting "on_restart" = "destroy", and then creating the domain.  Once the
install finished, the guest would die, host-status would detect this, and then
restart the guest with the hard drive as the boot device.  This would be similar
to how virt-install manages the problem.  However, that is kind of hacky, and
seems a little fragile since we are then going to depend on host-status to
update the status and restart the guest.
     The better way to do this is to have the remote node take care of the
details.  That is, with the messaging stuff, we would have an "install_vm"
remote call; then this entire operation would happen over on the node in
question, and we wouldn't have to have hacky model changes to support it.
     First, I wanted to be sure this was an approach people agreed with (or if
they had other ideas how to approach it).  Second, I wanted to make Ian aware
that this is one of the "ovirt-specific" methods that we are going to need in
the AMQP model, once that is in place.

Chris Lalancette


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]