[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Ovirt-devel] [PATCH ovirt-appliance] cleanup directory



Alan Pevec <apevec redhat com> wrote:

> Signed-off-by: Alan Pevec <apevec redhat com>
> ---
>  Makefile |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/Makefile b/Makefile
> index 58ae5e4..c51b04d 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -25,7 +25,7 @@ RPM_FLAGS += --define "ovirt_url $(OVIRT_URL)"
>  endif
>
>  clean:
> -	rm -f $(pkg_name)-*
> +	rm -rf $(pkg_name)-*
>
>  distclean: clean
>  	rm -rf tmp repos.ks rpm-build

Clearly a necessary improvement, since Makefile does this:

        mkdir -p $(NV)

and NV is defined (in release.mk) like this:

    NV              = $(pkg_name)-$(VERSION)

Hmm...
As I write this, I wonder about removing $(NV) instead.
That's a little more readable, since you don't have to
go look up where the heck $(pkg_name)-* was created
(finding the NV definition in a separate file).
Then there's the question of whether you want to remove
only this particular directory, or *all* with that prefix,
including $(pkg_name)-precious that I carefully renamed for
future reference ;-)

When I put it that way, I do prefer the more conservative
approach of dropping the wildcard and just using $(NV).

Either way's ok though.

ACK.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]