[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Ovirt-devel] [PATCH] Fixed the configuration setup to be more complete.



It now checks to ensure that the following dependencies are installed
on the system:

 * Ruby
 * Ruby development libraries
 * Rake
 * Ruby gem command

Signed-off-by: Darryl L. Pierce <dpierce redhat com>
---
 configure.ac |    8 ++++++++
 1 files changed, 8 insertions(+), 0 deletions(-)

diff --git a/configure.ac b/configure.ac
index 02f4050..6b9f833 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,5 +7,13 @@ AC_CONFIG_HEADERS([config.h])
 test x"$ac_ct_CC:$CFLAGS" = 'xgcc:-g -O2' \
   && CFLAGS="$CFLAGS -Wshadow -Wall -Werror"
 
+AC_CHECK_PROGS(RUBY, ruby rake gem)
+
+if test x"$RUBY" = x ; then
+   AC_MSG_ERROR([Missing ruby development programs.])
+fi
+
+AC_CHECK_LIB(ruby, main, , AC_MSG_ERROR[Cannot find ruby development libraries])
+
 AC_CONFIG_FILES([Makefile ovirt-server.spec])
 AC_OUTPUT
-- 
1.7.0.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]