[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Rebuilding Evolution 1.2.1 on phoebe



This message doesn't show up in the archives, so I'm not convinced that
it actually arrived at the list.  Resending, sorry if anybody sees this
twice.


Anybody tried to rebuild Evo 1.2.1 on phoebe?  I've been giving it a
shot, since there are a couple of patches I like to add.  Roughly, I add
my two patches to the spec file, and attempt to build the RPM, and I get
this output from RPM (sorry about the long lines, but I thought it
better to have them than risk confusing the output):

checking for db3 compiler flags... -I/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix
checking for db.h... yes
checking db3 header version... 3.1.17
checking for db3 library name... configure: error: Could not find db3 library
error: Bad exit status from /var/tmp/rpm-tmp.87668 (%build)

Clearly something db is horked.  Looking at Evolution's config.log, I
see:

configure:9738: checking for db3 library name
configure:9765: gcc -o conftest -O2 -march=i386 -mcpu=i686 -g -fPIC -Wall -Wunused -I/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix  -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  conftest.c  /home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/libdb.a 1>&5
/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/libdb.a(mut_pthread.o)(.text+0x86): In function `__db_pthread_mutex_init':
/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/../mutex/mut_pthread.c:107: undefined reference to `pthread_mutexattr_destroy'
/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/libdb.a(mut_pthread.o)(.text+0xac):/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/../mutex/mut_pthread.c:114: undefined reference to `pthread_condattr_destroy'
/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/libdb.a(mut_pthread.o)(.text+0xcb):/home/gleblanc/projects/rpm/BUILD/evolution-1.2.1/db-3.1.17/build_unix/../mutex/mut_pthread.c:110: undefined reference to `pthread_cond_init'

And so on, with a whole slew of other pthread related errors.  Anybody
have any thoughts on how to get this thing to compile?  Thanks,
	Greg

-- 
Gregory Leblanc <gleblanc linuxweasel com>





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]