[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm database corrupt



> On Fri, 5 Dec 2003, Ross Macintyre wrote:
>
>> Hi,
>>   I have a machine that has a corrup RPM database.
>> I tried the usual
>>   rm var/lib/rpm/__db.00*, then
>>   rpm --rebuilddb
>> which has worked in the past.
>> This time nothing.
>
> If rpm is getting stuck, rather than crashing, that often means some other
> process has the database locked. Look for such processes, or even reboot
> before removing the __db files. See also
> http://www.rpm.org/hintskinks/repairdb/
> for further rebuilding hints if necessary.

thanks to all who replied. Yes the problem was fixed by a reboot and a
rebuild. I got caught out here because 'df' (no args) wasn't hanging and
could be killed with ctrl-c. What I did find was that when I gave the
verbose option to rpm, I did see df failing on a particular mount point;
when I did try df on that mountpoint, it did hang and couldn't be
ctrl-c'd.

The trouble here was that I was loathe to reboot, and the lesson I've
learned is that I shouldn't rely on this server's RPM database(I was using
it to compare against other machines RPM database for consistency).

Thanks,

Ross
>
> 	Michael Young
>
>
> --
> Psyche-list mailing list
> Psyche-list redhat com
> https://www.redhat.com/mailman/listinfo/psyche-list
>


-- 
Ross Macintyre (raz macs hw ac uk)




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]