[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] RPM build error



On 07/01/2010 06:17 AM, Jason Dobies wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 07/01/2010 08:34 AM, Jason Dobies wrote:
On 06/30/2010 06:02 PM, Mike McCune wrote:
Jay, I get this when building the latest pulp:

+ find /home/mmccune/rpmbuild/BUILDROOT/pulp-0.0.32-1.fc11.x86_64 -name
'*.py'
+ xargs sed -i -e '/^#!\/usr\/bin\/env python/d' -e
'/^#!\/usr\/bin\/python/d'
+ setfacl -m user:apache:rwx /var/log/pulp
setfacl: /var/log/pulp: Operation not permitted
error: Bad exit status from /var/tmp/rpm-tmp.vPyPWO (%install)


RPM build errors:
     Bad exit status from /var/tmp/rpm-tmp.vPyPWO (%install)

Fixed.

Does --test no longer work in the newest tito? I was under the
impression that --test would use the local spec file, meaning I could
test it before I commit/tag it, which is why I thought this change
worked. But I just tried this and it doesn't seem to be the case. Is
there a different way of using tito I'm not aware of?



remember, --test works against the latest *committed* local version, not un-committed changes. It should work but I've seen it act weird where it will fail with --test but work fine with a tagged/pushed rev even thou the specfile didn't change.

what was the error or were you trying to --test with local uncommitted mods?

Mike


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]