[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Issues with pulp on rhel5



Sayli Karmarkar wrote:
I was able to successfully build and install pulp on rhel5 using python2.6 from epel repo. However after installing I ran into following issues:


1.  Error starting httpd:

Starting httpd: Syntax error on line 29 of /etc/httpd/conf.d/pulp.conf:
Invalid command 'WSGIProcessGroup', perhaps misspelled or defined by a module not included in the server configuration

2.

$ sudo pulp-admin repo list
Traceback (most recent call last):
File "/usr/bin/pulp-admin", line 18, in <module>
  from pulp.client.cli.base import PulpCLI
File "/usr/lib/python2.6/site-packages/pulp/client/cli/base.py", line 21, in <module>
  from pulp.client.credentials import Credentials
File "/usr/lib/python2.6/site-packages/pulp/client/credentials.py", line 23, in <module>
  from M2Crypto import X509
ImportError: No module named M2Crypto

So basically what is happening is pulp is installed under python2.6 site-packages where M2Crypto, iniparse etc. exist under python2.4 site-packages.

If  I add python2.4 site-packages in sys.path it gives warnings like:

/usr/lib/python2.4/site-packages/M2Crypto/__init__.py:14: RuntimeWarning: Python C API version mismatch for module __m2crypto: This Python has API version 1013, module __m2crypto has version 1012.
import __m2crypto

If anybody is has seen these issues or have some suggestions, let me know.

FYI, I have resolved this issue #2. wsgi related issue is still outstanding.

--
Sayli Karmarkar
skarmark redhat com

Systems Management
http://www.redhat.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]