[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] PULP - newby question.... pulp behind a proxy



Hello Mike,

thanks a lot for your answer!  Maybe I was not exact enough....
Here my pulp-server is behind a proxy. I've created a repo (feed: yum)
but cannot sync it:

Id                      f14-x86_64
Name                    f14-x86_64
FeedURL                 http://mirror.uoregon.edu/fedora/linux/releases/14/Fedora/x86_64/os
FeedType                yum
Arch                    noarch
Sync Schedule           None
Packages                0
Files                   0
Distributions           None
Publish                 True
Clones                  []
Groups                  None

and sync gives:

pulp-admin repo sync --id f14-x86_64 -F
Sync for repository f14-x86_64 started
You can safely CTRL+C this current command and it will continue
[                            ] 0%
Sync: Error
RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: . Please verify its path and try again

tracing the network shows that it never tries any connection to our proxy...

christian
 

-----Urspr√ľngliche Nachricht-----
Von: Mike McCune [mailto:mmccune redhat com] 
Gesendet: Freitag, 21. Jänner 2011 16:15
An: Masopust, Christian
Cc: 'pulp-list redhat com'
Betreff: Re: [Pulp-list] PULP - newby question.... pulp behind a proxy

On 01/20/2011 08:11 AM, Masopust, Christian wrote:
> tried google, searched the mail-archive... failed :-))
> what to configure if running pulp behind a proxy (http) ??
> thanks a lot,
> christian
>

I don't think our client yet supports connecting through a http proxy. 
I don't think it would be all that hard to add but I don't think it yet 
can do this.

Prad, correct me if I'm wrong ...

Mike
-- 
Mike McCune
mmccune AT redhat.com
Red Hat Engineering       | Portland, OR
Systems Management        | 650.254.4248


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]