[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] New Pulp installation - unknown errors



Hi Kevin,
 
just a wild guess.... I had a similar message yesterday and found out that mongodb was not
running (alltough startscript told that everything was ok...)
 
Christian


Von: pulp-list-bounces redhat com [mailto:pulp-list-bounces redhat com] Im Auftrag von Kevin Holmes
Gesendet: Dienstag, 25. Jänner 2011 22:02
An: pulp-list redhat com
Betreff: [Pulp-list] New Pulp installation - unknown errors

Hi everyone,

New Pulp install and I'm having a problem.

I cannot seem to issue any commands with the pulp cli tools.

For instance:

[root blueberry pub]# pulp-admin auth login -u admin -p admin
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 147, in ?
    admin.main()
  File "/usr/lib/python2.4/site-packages/pulp/client/cli/base.py", line 98, in main
    command.main(args[1:])
  File "/usr/lib/python2.4/site-packages/pulp/client/core/base.py", line 118, in main
    action.main(args[1:])
  File "/usr/lib/python2.4/site-packages/pulp/client/core/base.py", line 229, in main
    self.run()
  File "/usr/lib/python2.4/site-packages/pulp/client/core/auth.py", line 47, in run
    cert_dict = self.authconn.admin_certificate()
  File "/usr/lib/python2.4/site-packages/pulp/client/connection.py", line 671, in admin_certificate
    return self.conn.request_get(method)
  File "/usr/lib/python2.4/site-packages/pulp/client/connection.py", line 126, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.4/site-packages/pulp/client/connection.py", line 114, in _request
    self.validateResponse(response)
  File "/usr/lib/python2.4/site-packages/pulp/client/connection.py", line 122, in validateResponse
    raise RestlibException(response.status, response.read())
  File "/usr/lib/python2.4/site-packages/pulp/client/connection.py", line 50, in __init__
    super(RestlibException, self).__init__(code, msg)
TypeError: super() argument 1 must be type, not classobj


Corresponding Apache logs:

==> ssl_access_log <==
127.0.0.1 - - [25/Jan/2011:15:46:47 -0500] "GET /pulp/api//users/admin_certificate/ HTTP/1.1" 500 609

==> ssl_error_log <==
[Tue Jan 25 15:48:47 2011] [error] [client 127.0.0.1] Premature end of script headers: webservices.wsgi

==> ssl_request_log <==
[25/Jan/2011:15:46:47 -0500] 127.0.0.1 TLSv1 DHE-RSA-AES256-SHA "GET /pulp/api//users/admin_certificate/ HTTP/1.1" 609



Running user update also fails, but nothing shows up in my Apache logs.

[root blueberry pub]# pulp-admin user update
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 147, in ?
    admin.main()
  File "/usr/lib/python2.4/site-packages/pulp/client/cli/base.py", line 98, in main
    command.main(args[1:])
  File "/usr/lib/python2.4/site-packages/pulp/client/core/base.py", line 118, in main
    action.main(args[1:])
  File "/usr/lib/python2.4/site-packages/pulp/client/core/base.py", line 228, in main
    self.setup_connections()
  File "/usr/lib/python2.4/site-packages/pulp/client/core/user.py", line 37, in setup_connections
    system_exit(-1, ce.message)
AttributeError: CredentialError instance has no attribute 'message'


So far this seems like a really cool project. I hope to get it working on our systems in the future.

- Kevin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]