[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Error 401 working with pulp via katello



Afternoon - I tried asking this on IRC to no avail (no response).

I've got a Katello server running from git (master at the moment, but
doesn't seem to matter), trying to utilize the 0.4.3 version of
Candlepin and pulp-0.0.196-1.fc14.noarch.  (although the same error
manifests itself with 0.192).

Essentially Katello is trying to communicate via oauth to the pulp
server.  I've got matchin oauth keys and secrets across the board, yet
I'm getting a 401 unauthorized when working with pulp and the only
useful error is the following within the pulp.log in /var/log/pulp


2011-06-23 12:52:04,123 24410:140037171181312:
pulp.server.auth.authentication:ERROR: authentication:211 error
verifying OAuth signature: Invalid signature. Expected signature base
string:
GET&https%3A%2F%2Flocalhost%2Fpulp%2Fapi%2Fusers%2F&oauth_consumer_key%3Dkatello%26oauth_nonce%3DoSRYI6dQ07h9oefNwIXrVX2Y0c6BZomx8FXFOFysuY%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1308855124%26oauth_version%3D1.0


This is all on the same server (my machine), so oauth time issues
shouldn't be a problem.

I'm really not sure how to move forward with this and it's a blocker.
Any ideas?  Has anyone seen this?

-J



-- 
Jason E. Rist
Senior Software Engineer
Systems Management and Cloud Enablement
Red Hat, Inc.
+1.919.754.4048
Freenode: jrist


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]