[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Creating errata



On 9/1/11 9:23 AM, Lukas Zapletal wrote:
Hello,

I synced my testing repo with two erratas in it. Well I manually edited the updateinfo.xml file and I hope it is valid, Pulp did not complain syncing it and I can see both erratas in the list.

Now, I want to install an errata to pulp consumer. So I registered and bound the consumer to the repo above. Then I issued:

pulp-admin errata install --consumerid dea -e RHEA-2010:0001

(Btw there is an "-e" missing in the user guide chapter Errata, paragraph Installation).

But it says:

error: operation failed: Errata ['RHEA-2010:0001'] you requested are not applicable for your system

What are possible reasons for this? Once I am registered, errata is listed and I don't have any of the packages it should install.

Errata is only applicable to your consumer if there is an older version of the package associated to that errata on your system and package profile has been updated on pulp for that consumer.

So for example:

Say you have errata RHBA-2011-0986 and it has zsh-1.4 in its package list. You can only install this errata on your consumer if that consumer has a version of zsh older than 1.4 already installed.



I also tried to create new errata (with no packages):

pulp-admin errata create --id RHEA-2010:0001 --title "Testing issue" --version 1 --release 1 --type security --issued "2010-01-01 01:01:01" --status stable --fromstr "lzap+pub redhat com" --effected-packages ~/empty

I wonder why don't I specify the repo I want to create errata in. Anyways when I try to install it I got the same result.

Your errata should have some package associated to it to be applicable. Errata is just an information file giving you info on what these new package that you're about to install provide. So errata itself has nothing to be installed, Its the package in the errata that matter to you.

Hope this helps. Feel free to ping me on irc if you need help.

~ Prad


I must have done something wrong. Thanks for explanation.

LZ



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]