[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] New to pulp and I receive SASL errors trying to set up consumers



Harm and Jay,

Thanks so much for the info. Worked like a charm. Now back to trying to
figure it all out.
--
"A child of five would understand this!
Send someone to fetch a child of five!"
-- Groucho Marx

Bruce Lundberg
freenode nickname: science_gone_bad

Linux Sys Admin and Security Engineer




On 8/3/12 7:00 AM, "Jay Dobies" <jason dobies redhat com> wrote:

>On 08/03/2012 08:42 AM, Harm Kroon wrote:
>> I've run into the same issue when I was playing with my reinstalled
>>test setup. Trying to register a CDS on the server gave the same error.
>> Setting "auth=no" in /etc/qpidd.conf and restarting pulp-server and
>>-cds fixed things for me.
>>
>> (although I'm not sure if that's the desired solution, as I'm also very
>>new to pulp).
>>
>> Grtz, Harm
>
>Harm is right, I ran into this too. Somewhere in 6.x qpid started
>shipping with auth set to on by default. Without configuring Pulp to
>authenticate against qpid, it's not going to work out of box. Turning
>off auth on qpid (which is used both for consumers and CDS instances)
>should resolve those issues.
>
>
>>
>> -----Original Message-----
>> From: pulp-list-bounces redhat com
>>[mailto:pulp-list-bounces redhat com] On Behalf Of Nick Coghlan
>> Sent: Friday, August 03, 2012 5:16 AM
>> To: pulp-list redhat com
>> Subject: Re: [Pulp-list] New to pulp and I receive SASL errors trying
>>to set up consumers
>>
>> On 08/03/2012 07:08 AM, Lundberg, Bruce wrote:
>>> Since things weren't adding up, I decided to clean everything up and
>>> start over I unbound the repository from stapatch01, but now I cannot
>>> unregister any of the consumers neither from the server nor from
>>> either of the consumer systems. The error I get from all systems is:
>>>
>>>   error:  operation failed: AuthenticationFailure: Error in
>>> sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error:
>>> Unspecified GSS failure.  Minor code may provide more information
>>> (Credentials cache file '/tmp/krb5cc_48' not found)
>>>
>>> There are no SASL credential files in /tmp. The pulp-server was
>>> restarted when I made some firewall changes, but nothing else has
>>> changed. I've searched the Web, the pulp mail archives, and am asking
>>> about on the freenode IRC channel. I can't find any information on how
>>> to clean this up. Any help would be greatly appreciated.
>>
>> That sounds very odd - as far as I am aware, Pulp 1.1 doesn't support
>>Kerberos at all (I had to patch my local version to handle it, and it
>>was a bit of a hack: https://bugzilla.redhat.com/show_bug.cgi?id=831937).
>>
>> However, that error suggests *something* in the client is trying to log
>>in with Kerberos and complaining that it can't find a valid ticket. If
>>you were trying to use PulpDist's custom client I'd understand seeing
>>that error, but I have no idea how you could get the normal clients to
>>trigger it (unless 1.x has changed even more than I thought since I last
>>updated from upstream).
>>
>> Regards,
>> Nick.
>>
>> --
>> Nick Coghlan
>> Red Hat Infrastructure Engineering & Development, Brisbane
>>
>> _______________________________________________
>> Pulp-list mailing list
>> Pulp-list redhat com
>> https://www.redhat.com/mailman/listinfo/pulp-list
>>
>> _______________________________________________
>> Pulp-list mailing list
>> Pulp-list redhat com
>> https://www.redhat.com/mailman/listinfo/pulp-list
>>
>
>
>-- 
>Jay Dobies
>Freenode: jdob @ #pulp
>http://pulpproject.org | http://blog.pulpproject.org
>
>_______________________________________________
>Pulp-list mailing list
>Pulp-list redhat com
>https://www.redhat.com/mailman/listinfo/pulp-list




--
 The sender of this email subscribes to Perimeter E-Security's email
 anti-virus service. This email has been scanned for malicious code and is
 believed to be virus free. For more information on email security please
 visit: http://www.perimeterusa.com/services/messaging
 This communication is confidential, intended only for the named recipient(s)
 above and may contain trade secrets or other information that is exempt from
 disclosure under applicable law. Any use, dissemination, distribution or
 copying of this communication by anyone other than the named recipient(s) is
 strictly prohibited. If you have received this communication in error, please
 delete the email and immediately notify our Command Center at 203-541-3444.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]