[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] New to pulp and I receive SASL errors trying to set up consumers



On 08/03/2012 11:00 PM, Jay Dobies wrote:
> On 08/03/2012 08:42 AM, Harm Kroon wrote:
>> I've run into the same issue when I was playing with my reinstalled
>> test setup. Trying to register a CDS on the server gave the same error.
>> Setting "auth=no" in /etc/qpidd.conf and restarting pulp-server and
>> -cds fixed things for me.
>>
>> (although I'm not sure if that's the desired solution, as I'm also
>> very new to pulp).
>>
>> Grtz, Harm
> 
> Harm is right, I ran into this too. Somewhere in 6.x qpid started
> shipping with auth set to on by default. Without configuring Pulp to
> authenticate against qpid, it's not going to work out of box. Turning
> off auth on qpid (which is used both for consumers and CDS instances)
> should resolve those issues.

Ah, that would explain why I haven't run into the problem - I currently
have the qpid integration disabled completely until I get around to
setting it up properly (it's on the todo list! Somewhere...)

Cheers,
Nick.

-- 
Nick Coghlan
Red Hat Infrastructure Engineering & Development, Brisbane


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]