[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] [Pulp v1] Command "pulp-admin repo content" sees RPM in pulp repo but yum install not



Meanwhile, manually inspecting the metadata in "vnet-el6-noarch", I noticed that filelists.xml.gz, primary.xml.gz, filelists.sqlite.bz2, primary.sqlite.bz2 are all empty, i.e.

$ zless filelists.xml.gz

<?xml version="1.0" encoding="UTF-8"?>
<filelists xmlns="http://linux.duke.edu/metadata/filelists"; packages="0">
</filelists>

and

$ sqlite3 filelists.sqlite
...
sqlite> select * from packages;
sqlite>

both say that there are no packages in my repository. Seems as if I made a really stupid mistake. This is the sequence of commands I use to publish an rpm into pulp:

$ /usr/bin/pulp-admin -u admin -p admin content upload --nosig --verbose --dir /home/me/publish $ /usr/bin/pulp-admin -u admin -p admin repo add_package --id vnet-el6-noarch --package=logstash-1.1.0-20120412051047.el6.noarch.rpm

Is there anything I'm doing wrong here?

Regards,
Olaf
Hello,

I'm experimenting with using pulp as our future in-house yum repository for hosting home-grown rpms. To that end, I recently installed pulp v1 and created a repository. I did so closely following instructions found in pulp's user guide, setting up pulp server and pulp consumer on the same machine, a centos 6.2 box.

Issuing "pulp-admin repo content --id=vnet-el6-noarch" yields

+------------------------------------------+
         Contents of vnet-el6-noarch
+------------------------------------------+

Packages in vnet-el6-noarch:

logstash-1.1.0-20120412014331.el6.noarch.rpm
logstash-1.1.0-20120412020706.el6.noarch.rpm
logstash-1.1.0-20120412023313.el6.noarch.rpm
logstash-1.1.0-20120412031002.el6.noarch.rpm
logstash-1.1.0-20120412033853.el6.noarch.rpm
logstash-1.1.0-20120412040811.el6.noarch.rpm
logstash-1.1.0-20120412043412.el6.noarch.rpm
logstash-1.1.0-20120412051047.el6.noarch.rpm
logstash-1.1.0-20120412053645.el6.noarch.rpm
logstash-1.1.0-20120412061401.el6.noarch.rpm

Errata in vnet-el6-noarch:

 none

Files in vnet-el6-noarch:

 none

After registering the server machine as a consumer and binding that consumer to "vnet-el6-noarch", issuing the command "pulp-consumer repo list" yields

+------------------------------------------+
       List of Available Repositories
+------------------------------------------+

Id                     vnet-el6-noarch
Name                   vnet-el6-noarch
Repo URL https://dev.vhost.net/pulp/repos/vnet-el6-noarch/
Feed URL               None
Feed Type              None
Content Type           yum
Feed Certs             CA:No   Cert:No
Consumer Certs         CA:No   Cert:No
Architecture           noarch
Sync Schedule          None
Packages               11
Files                  0
Distributions          None
Publish                True
Clones                 []
Groups                 None
Filters                []
Notes                  {}
Preserve Metadata      False
Checksum Type          sha256

Looking into /etc/yum.repos.d/pulp.repo I see

#
# Pulp Repositories
# Managed by Pulp client
#

[vnet-el6-noarch]
name = vnet-el6-noarch
enabled = 1
sslverify = 0
gpgcheck = 0
baseurl = https://dev.vhost.net/pulp/repos/vnet-el6-noarch

Alas, yum does not find my homegrown logstash rpm, i.e. yum clean all && yum search logstash fails to return a match. Likewise, running "yum --disablerepo=* --enablerepo=vnet-el6-noarch list available" returns

Loaded plugins: fastestmirror, presto, pulp-profile-update
Loading mirror speeds from cached hostfile

and that's it. For reference, here is the output from running "yum --version":

3.2.29
  Installed: rpm-4.8.0-19.el6_2.1.x86_64 at 2012-04-02 08:31
Built : CentOS BuildSystem <http://bugs.centos.org> at 2012-04-03 17:03
  Committed: Panu Matilainen <pmatilai redhat com> at 2012-02-27

  Installed: yum-3.2.29-22.el6.centos.2.noarch at 2012-03-06 02:42
Built : CentOS BuildSystem <http://bugs.centos.org> at 2012-03-14 03:23
  Committed: Johnny Hughes <johnny centos org> at 2012-03-07

Installed: yum-plugin-fastestmirror-1.1.30-10.el6.noarch at 2011-12-21 15:01 Built : CentOS BuildSystem <http://bugs.centos.org> at 2011-12-07 21:07
  Committed: James Antill <james antill redhat com> at 2011-09-21

Has someone an explanation for this phenomenon, or could at least point me to where to look next? Any help will be greatly appreciated.

Regards,
Olaf Bergner

_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]