[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Package pulp is obsoleted by pulp-server error



On Mon, Jul 16, 2012 at 08:16:25AM -0400, Jay Dobies wrote:
> On 07/16/2012 06:17 AM, Lukas Zapletal wrote:
> >Package pulp is obsoleted by pulp-server, but obsoleting package does
> >not provide for requirements
> >
> >Then it fails to install "pulp". We do not want to change to
> >"pulp-server" yet since we need to be back-compatible for some time
> >(using various pulp versions) in Katello.
> >
> >Is the obsoleted pulp package reason for our errors? What is the status?
> >
> >Thanks
> 
> Which repository are you using?
> 
> If it's the v2 ones, the RPMs were restructured for v2; there is no
> "pulp" package anymore. You can't have v1 and v2 installed side by
> side due to a number of reasons.

I understand, can you please make sure installation using old approach:

yum install pulp

would still work? We can switch to "pulp-server" in the future, but we
need some "transition window". We hard-require this in the katello.spec.
I guess this would be needed for that:

Provides: oldpackagename = $provEVR
Obsoletes: oldpackagename < $obsEVR

Thanks

LZ

-- 
Later,

 Lukas "lzap" Zapletal
 #katello #systemengine


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]