[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Grinder problem when syncing from RHN



Hi,

We are using grinder to dump the content of the RHN and import it into our Pulp server. We have valid Satellite subscription and a valid Satellite certificate we are using for grinder. This worked very well until few days ago when we started seeing following errors:

# grinder rhn -C /etc/grinder/grinder.yml --debug
[...]
grinder.RHNSync: INFO     1255 <rhel-x86_64-server-supplementary-5> packages are available, getting list of short metadata now.
send: 'POST /SAT-DUMP/ HTTP/1.0\r\nX-RHN-Satellite-XML-Dump-Version: 3.4\r\nUser-Agent: xmlrpclib.py/1.0.1 (by www.pythonware.com)\r\nContent-Type: text/xml\r\nContent-Length: 66252\r\n\r\n'
send: '<?xml version=\'1.0\'?>\n<methodCall>\n<methodName>dump.packages_short</methodName>\n[...]'
reply: 'HTTP/1.1 200 OK\r\n'
header: Date: Tue, 24 Jul 2012 14:40:24 GMT
header: Server: Apache
header: Content-Encoding: gzip
header: Content-Type: application/octet-stream
header: Connection: close
body: '\x1f\x8b\x08\x002\xb4\x0eP\x02\xff\xc4\xbd\xdb\xb2\x1d\xc7\x8d-\xfa+\x0e\xbd\x93[...]'
Traceback (most recent call last):
  File "/usr/bin/grinder", line 23, in <module>
    GrinderCLI.CLI().main()
  File "/usr/lib/python2.6/site-packages/grinder/GrinderCLI.py", line 457, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/grinder/GrinderCLI.py", line 59, in main
    self._do_command()
  File "/usr/lib/python2.6/site-packages/grinder/GrinderCLI.py", line 179, in _do_command
    savePath, self.rhnSync.getVerbose())
  File "/usr/lib/python2.6/site-packages/grinder/RHNSync.py", line 378, in syncPackages
    pkgInfo = satDump.getShortPackageInfo(self.systemid, packages, filterLatest = not self.fetchAll)
  File "/usr/lib/python2.6/site-packages/grinder/SatDumpClient.py", line 119, in getShortPackageInfo
    dom = self.client.dump.packages_short(systemId, listOfPackages)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__2
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib/python2.6/site-packages/grinder/rhn_transport.py", line 82, in _parse_response
    p.feed(unzippedResponse)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 601, in feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 1, column 0

grinder.yml has the following content:

url: http://satellite.rhn.redhat.com
cert: /etc/sysconfig/rhn/lhrsat04.xml
systemid: /etc/sysconfig/rhn/systemid
all: True
parallel: 20
verbose: False
removeold: False
num_old_pkgs_keep: 2
basepath: /var/lib/pulp/rhn
channels:
-    label: rhel-x86_64-server-supplementary-5
     relpath: rhel/5/supplementary

grinder version is: grinder-0.0.147-1.el6.noarch

From time to time we also get "502 Bad gateway", so this does seem like a RHN problem. Does anyone know if there were any changes in RHN that could break grinder? Or if there are some on-going issues in RHN that are impacting grinder's functionality?

Thanks,
Miljan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]