[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] repo sync fails using rhel5.7 iso



Yea this turned out to be a known issue with RHEL 5 isos. This will be resolved in  the upcoming U releases. I documented a workaround here,

https://fedorahosted.org/pulp/wiki/UGFAQ#SyncingcontentonpulpfromamountedRHEL5isofailstolookuptreeinfo

Lemme know if you have any issues,

~ Prad

On 02/29/2012 05:09 PM, Golden, Joel wrote:
The .treeinfo only resides in the root directory of the .iso and there is no repodata dir in the root dir.  Conundrum...


From: Pradeep Kilambi [mailto:pkilambi redhat com]
Sent: Wednesday, February 29, 2012 12:24 PM
To: Golden, Joel
Cc: pulp-list redhat com
Subject: Re: [Pulp-list] repo sync fails using rhel5.7 iso

There needs to be a .treeinfo file in the directory for us to be able to create a distribution. Usually it should be at the same level as where the repodata is.

~ Prad

On 02/29/2012 01:39 PM, Golden, Joel wrote:
If I point it to the Server directory that contains the repodata directory (rhel-server-5.7-x86_64-dvd.iso/Server/), then it does not create any trees and I do not get a distribution list that I can kickstart from.  What am I missing?
 
Joel


From: pulp-list-bounces redhat com [mailto:pulp-list-bounces redhat com] On Behalf Of Pradeep Kilambi
Sent: Wednesday, February 29, 2012 11:34 AM
To: pulp-list redhat com
Subject: Re: [Pulp-list] repo sync fails using rhel5.7 iso

Make sure your file path is pointing to the dir where repodata  is found. Error indicates that there is no repodata dir under /var/tmp/rh5u7-base/ .

~ Prad

On 02/29/2012 12:31 PM, Golden, Joel wrote:
I've banged my head on this for a few days now and have thrown in the towel.  From a rhel6 box running pulp 254-8 I'm getting the following error when attempting to sync a repo using the rhel5.7 iso or a folder that is a copy of the iso.  I can sync it from the copy if I run a create repo from the base directory but run into a "Cannot retrieve metadata (repomd.xml)" error during the ks build.
 
pulp-admin repo create --id rh5u7-base --feed file:///var/tmp/rh5u7-base/ --arch x86_64
 
Error when attempting to sync:
error:  RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: /tmp/temp_pulp_repoH3jzwl. Please verify its path and try again

Best Regards,

Joel Golden, RHCE

  

-------------

    

The content contained in this electronic message is not intended to constitute formation of a contract binding tw telecom. tw telecom will be contractually bound only upon execution, by an authorized officer, of a contract including agreed terms and conditions or by express application of its tariffs. This message is intended only for the use of the individual or entity to which it is addressed. If the reader of this message is not the intended recipient, or the employee or agent responsible for delivering the message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this message is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the sender of this E-Mail or by telephone.




_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]