[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Developers: Action Required: The migration that pulp_rpm now has, and what it means for devs



On Thu, 08 Nov 2012 09:26:28 -0500, Randy Barlow <rbarlow redhat com> wrote:
If you are a developer and you wish to apply this migration, you will need to take the following steps:

1) $ pulp-manage-db

2) $ mongo pulp_database

3) > db.migration_trackers.update({'name': 'pulp_rpm.migrations'}, {'$set': {'version': 0}})

4) $ pulp-manage-db

I forgot to mention that there is another step that you need to do before all of this, step 0. You must reinstall the pulp_rpm project using its setup.py so that the entry point gets setup correctly on your system. If pulp-manage-db doesn't show "Migration package pulp_rpm.migrations is up to date at version 1" when it runs, then the pulp_rpm migrations were not applied.

--
Randy Barlow


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]