[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] can't install packages with pulp



Hey Cristian,

In pulp 2.x, the content type support is packaged separately on the agent as well as the server. You just need to install the Content Handler for the 'rpm' content type on your consumer(s) as follows:

1. yum install pulp-rpm-handlers
2. service pulp-agent restart

Then, retry your package install.

On 04/23/2013 04:17 AM, Cristian Falcas wrote:
I have a similar error when trying to do the bind:

2013-04-23 12:10:05,862 [INFO][worker-0] dispatch() @
dispatcher.py:646 - request: {'classname': 'Consumer', 'kws': {},
'args': [[{'repo_id': 'pulp-v2-beta-6Server', 'details': {'ca_cert':
None, 'server_name': 'oracle2', 'relative_path':
'/pulp/repos//pulp/v2/beta/6Server/x86_64/', 'gpg_keys': [],
'client_cert': None, 'protocols': ['http'], 'repo_name':
'pulp-v2-beta-6Server'}, 'type_id': 'yum_distributor'}], {}],
'method': 'bind', 'cntr': None}
2013-04-23 12:10:05,863 [ERROR][worker-0] bind() @ dispatcher.py:234 -
handler failed
Traceback (most recent call last):
   File "/usr/lib/python2.6/site-packages/pulp/agent/lib/dispatcher.py",
line 229, in bind
     handler = self.__handler(type_id, BIND)
   File "/usr/lib/python2.6/site-packages/pulp/agent/lib/dispatcher.py",
line 345, in __handler
     raise HandlerNotFound(type=type_id)
HandlerNotFound: No handler for: {'type': 'yum_distributor'}
2013-04-23 12:10:05,864 [INFO][worker-0] sendreply() @ rmi.py:156 -
5a5f95bc-31f7-4d32-ae61-cf2fc19ff862 processed in: 34 (ms)




On Tue, Apr 23, 2013 at 11:49 AM, Cristian Falcas
<cristi falcas gmail com> wrote:
Hello,

When I try to install a package I get this error:


[root oracle2 ~]# pulp-admin rpm consumer package install run
--consumer-id oracle4 --name zabbix20-agent
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin
Install Failed

No handler for: {'type': 'rpm'}

I only found this bug with the same error:
https://bugzilla.redhat.com/show_bug.cgi?id=850930

But I already have the python-rhsm package installed.

Anyone has any idea why is this happening?

Best regards,
Cristian

_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]