[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Creating RHEL 5 compatible yum repositories

Prelude: This is in response to BZ1042208 [0], "rpm metadata ignores
--checksum-type from repository"

Has anyone else experienced issues/victories using pulp 2.1+ to create
YUM repositories which are compatible with RHEL 5?

Specifically, I am referring to pulp setting/not setting the checksum
type of a newly created repository correctly?

I have a large number of RHEL 5 boxen to maintain and when we migrated
to Pulp 2.1 from 1.x we began seeing an issue where:

> pulp-admin ... rpm repo create --checksum-type sha ...

does not honor the '--checksum-type' option [1], and instead creates all new
repositories of type SHA256. This causes a backwards compatibility issue
with our RHEL 5 boxes who only support the SHA checksum type.

I am aware of the python-hashlib package, and have verified that
installing it successfully allows RHEL 5 boxen to consume repositories
of the SHA256 checksum type. However, IMHO this is a non-obvious work
around, and not a change I (or other system administrators) can
potentially make across my entire RHEL 5 infrastructure without a lot of
coordination and approvals.

Thanks for any advice!

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1042208
[1] https://github.com/juicer/juicer/issues/202

Tim Bielawa, Senior Release Engineer/Scribe, Inception
Why Should I Care What Color the Bikeshed Is?
919.332.6411 Cell | IRC: tbielawa (#inception)
1BA0 4FAB 4C13 FBA0 A036  4958 AD05 E75E 0333 AE37

Attachment: pgpwWq9T7qGfX.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]