[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] pulp meta-packages discontinued in 2.0.6



The newly released pulp 2.0.6 includes a packaging change. The meta-packages included in <= 2.0.5 have been discontinued and are no longer provided in the distribution.

The meta-packages were defined as follows:

meta-package: pulp-rpm-server
includes:
  Pulp Server
  RPM Plugins

meta-package: pulp-rpm-admin-client
includes:
  Admin CLI
  RPM Extensions

meta-package: pulp-rpm-consumer-client
includes:
  Consumer CLI
  RPM Extensions

pulp-rpm-agent
includes:
  Agent
  RPM Content Handlers


This functionality has been replaced with comps.xml groups.

The groups are defined as follows:

group: pulp-server
includes:
  Pulp Server
  RPM Plugins
  Puppet Plugins
  SELinux

group: pulp-admin
includes:
  Admin CLI
  RPM Extensions
  Puppet Extensions

group: pulp-consumer
includes:
  Consumer CLI
  RPM Extensions
  Puppet Extensions
  Pulp Agent
  RPM Content Handlers
  Puppet Content Handlers


Users upgrading from 2.0.5 using a command like: 'yum update \*pulp\*' may experience unresolved dependencies if 2.0.5 meta-packages are installed. To remedy this, simply uninstall the meta-packages and re-run the yum update.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]