[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Upgrade 1.0.0->1.1.14->2.11 fails with "openoffice.org must not contain dot"



Hi,
I updated Pulp 1.0.0 to 1.1.14 according to http://www.pulpproject.org/2012/05/24/pulp-v1-1-10-release/ and https://fedorahosted.org/pulp/wiki/PackagePathUpdate with a simple yum upgrade and ran "pulp-package-migrate -d /var/lib/pulp/ --migrate" to update the pathnames to include the full hash -- which worked fine.
 
Then I updated to 2.11 following https://pulp-user-guide.readthedocs.org/en/pulp-2.1/v1_upgrade.html. The "pulp-v1-upgrade" fails with the error "InvalidDocument: key 'openoffice.org-langpack-en' must not contain '.'".
 
I found that issue in the Pulp FAQ on https://fedorahosted.org/pulp/wiki/UGFAQ#rpmname but the recommended solution doesn't help. "yum downgrade pymongo-1.9-6.el6.x86_64.rpm python-bson-1.9-6.el6.x86_64.rpm" complains about Pulp needing at least pymongo-2.1.1. With a manual "rpm -Uvh --oldpackage --nodeps pymongo-1.9-6.el6.x86_64.rpm" I can install the former pymongo and python-bson packages but the pulp-v1-upgrade script still exits with the error mentioned above.

I run RHEL 6.3 with mongodb-server-1.8.2-2.
 
Any ideas?
 
Best,
Freerk


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]