[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Celery-Qpid Work In Progress



For those following the upcoming Pulp 2.4 release, you may have heard about Pulp's use of Celery[1].  Given this dependency, one challenge is that Celery does not work with the Apache Qpid[2], the preferred broker of Pulp.  Over the past few weeks, my focus with Pulp development has been to extend Kombu[3], a library underneath Celery, to allow Celery and Kombu to interoperate with Qpid as a message broker.  I've created a technical writeup of the work done to date, some of the issues we have run into, and the planned solutions to resolve those issues.  For those who are interested, you can read about it here:

https://fedorahosted.org/pulp/wiki/AMQP%201.0%20Support%20for%20Celery

Best,
Brian


[1]:  http://www.celeryproject.org/
[2]:  http://qpid.apache.org/
[3]:  http://kombu.readthedocs.org/en/latest/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]